WordPress2.7插件TinyMCE Advanced 修正下載

文章搜尋

tinymce-001

上星期在ALU將「i-Live」的後台也從2.6.2一次升級到2.7版後,隨筆就一直無法使用「TinyMCE Advanced」這個插件。上次ALU也在「WordPress 發文無法切換預覽模式」這篇文章中提到「TinyMCE Advanced」的最新版本3.2與WordPress 2.7似乎有不相容的情形;但是隨筆不死心再翻遍繁體網頁找不到快速解決的方法後,隨筆轉向官方網站(英文…看得好累!),

隨筆在官方網站中找到的資訊是「TinyMCE Advanced」的確支援WordPress2.7版,但是這隻插件是為英文語系所寫的…而在官網上也同時提供了繁體中文的語言包,所以隨筆就試著更新「i-Live」後台的「TinyMCE Advanced」插件,而很神奇的居然給隨筆蒙對了。

tinymce-002

目前更新後的「TinyMCE Advanced」插件是否有問題,隨筆尚未遇到;只是在3.2版的TinyMCE編輯區介面會有灰灰的顏色框住已輸入文字的編輯區區塊,雖然對發文沒有影響可是隨筆就是不愛,所以隨筆就將編輯區介面又改回了3.1的樣式…最後為了測試一下,就來篇發文測試測試,大家現在看到的這篇就是更新後的「TinyMCE Advanced」插件所編輯的文章。

現在隨筆又可以在後台編輯文章了…真是可喜可賀!!


i-Live後台使用的版本(隨筆亂改的)


插件名稱:Tinymce-Advanced

插件語系:繁體中文

執行環境:WordPress2.7版

下載:

Download Tinymce-Advanced Version 3.2



P.S.TinyMCE Advanced 語系官方下載網頁:

http://tinymce.moxiecode.com/download_i18n.php

(Visited 27 times, 1 visits today)

4 thoughts on “WordPress2.7插件TinyMCE Advanced 修正下載

  1. Carrie

    請問語系檔是直接放在 TinyMCE Advanced 資料夾裏嗎?

    還有,不知道你有沒安裝 Exec-PHP 這個插件?我發覺這兩個插件好像會相衝突,請問我是要在個人資訊那邊勾選 Exec-PHP Settings 的 Disable WYSIWYG Conversion Warning 嗎?還是說 TinyMCE Advanced 有針對 PHP 的 plugins 可以使用?因為我有時會在文章裏寫 PHP 的 code,怕切換到 HTML 寫下 code 之後,又被 TinyMCE Advanced 給吃掉,或是把我辛苦寫出的文章格式樣式更改掉、造成變形,請問你曾經發生這種情形嗎?

    不好意思,一來就問你連串的問題,實在因為我之前都是使用 WP 自帶的編輯器(不是 WYSIWYG 所見即所得的編輯器),所以怕使用了 WYSIWYG 會造成這樣的情形,所以才會提出這麼多問題。

    Reply
    1. 數碼隨筆 Post author

      Carrie你好:
      關於語系檔,
      1.如果你是下載官方的檔案,則要將語系檔放入TinyMCE Advanced 資料夾內所有相關的資料夾(有好幾個地方)。
      2.如果你下載本站的TinyMCE Advanced,隨筆已經放好了,目前使用正常。
      關於Exec-PHP,目前沒使用。隨筆怕麻煩都是直接貼PHP語法的圖檔(jpg)。

      Reply
  2. Carrie

    @數碼隨筆
    原來如此,我是下載你的修改版,啟用之後在個人資訊那邊勾選了 Exec-PHP Settings 的 Disable WYSIWYG Conversion Warning,然後就不再衝突了,多謝你提供的修改版喔!

    Reply

發表迴響